summaryrefslogtreecommitdiffstats
path: root/Tests/Assembler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Assembler/CMakeLists.txt')
-rw-r--r--Tests/Assembler/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/Tests/Assembler/CMakeLists.txt b/Tests/Assembler/CMakeLists.txt
index 456e496..5f71036 100644
--- a/Tests/Assembler/CMakeLists.txt
+++ b/Tests/Assembler/CMakeLists.txt
@@ -18,16 +18,16 @@ if("${CMAKE_GENERATOR}" MATCHES "Makefile")
DEPENDS main.c
VERBATIM
)
- endif(("${CMAKE_C_COMPILER_ID}" MATCHES "^(GNU|HP|SunPro|XL)$") OR ("${CMAKE_C_COMPILER_ID}" STREQUAL "Intel" AND UNIX))
-endif("${CMAKE_GENERATOR}" MATCHES "Makefile")
+ endif()
+endif()
if(SRCS)
set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS}")
enable_language(ASM OPTIONAL)
-else(SRCS)
+else()
message(STATUS "No assembler enabled, using C")
set(SRCS main.c)
-endif(SRCS)
+endif()
add_executable(HelloAsm ${SRCS})