summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index be0b3f9..d840b96 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -195,9 +195,7 @@ IF(BUILD_TESTING)
# run test for BundleUtilities on supported platforms/compilers
- find_program(DUMPBIN_EXECUTABLE NAMES dumpbin)
- mark_as_advanced(DUMPBIN_EXECUTABLE)
- if(MSVC OR DUMPBIN_EXECUTABLE OR
+ if(MSVC OR
CMAKE_SYSTEM_NAME MATCHES "Linux" OR
CMAKE_SYSTEM_NAME MATCHES "Darwin")
ADD_TEST(BundleUtilities ${CMAKE_CTEST_COMMAND}
@@ -209,7 +207,7 @@ IF(BUILD_TESTING)
--build-project BundleUtilities
)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/BundleUtilities")
- endif(MSVC OR DUMPBIN_EXECUTABLE OR
+ endif(MSVC OR
CMAKE_SYSTEM_NAME MATCHES "Linux" OR
CMAKE_SYSTEM_NAME MATCHES "Darwin")