summaryrefslogtreecommitdiffstats
path: root/Tests/COnly/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/COnly/CMakeLists.txt')
-rw-r--r--Tests/COnly/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/COnly/CMakeLists.txt b/Tests/COnly/CMakeLists.txt
index de277fe..c4d76e0 100644
--- a/Tests/COnly/CMakeLists.txt
+++ b/Tests/COnly/CMakeLists.txt
@@ -12,3 +12,9 @@ if(MSVC_VERSION)
endif(MSVC_VERSION)
string(ASCII 35 32 67 77 97 107 101 ASCII_STRING)
message(STATUS "String: ${ASCII_STRING}")
+get_source_file_property(LANG conly.c LANGUAGE)
+if("${LANG}" STREQUAL "C")
+ message("Language is C")
+else("${LANG}" STREQUAL "C")
+ message(FATAL_ERROR "Bad language for file conly.c")
+endif("${LANG}" STREQUAL "C")