summaryrefslogtreecommitdiffstats
path: root/Tests/CPackComponents/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CPackComponents/CMakeLists.txt')
-rw-r--r--Tests/CPackComponents/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/CPackComponents/CMakeLists.txt b/Tests/CPackComponents/CMakeLists.txt
index d41faa0..862d139 100644
--- a/Tests/CPackComponents/CMakeLists.txt
+++ b/Tests/CPackComponents/CMakeLists.txt
@@ -39,6 +39,9 @@ install(TARGETS mylibapp
install(FILES mylib.h
DESTINATION include
COMPONENT headers)
+install(FILES "Issue 7470.html"
+ DESTINATION docs
+ COMPONENT documentation)
if(mylib_install_to_absolute_path)
install(FILES mylib.cpp
@@ -77,6 +80,11 @@ cpack_add_component(applications
DESCRIPTION "An extremely useful application that makes use of MyLib"
GROUP Runtime
INSTALL_TYPES Full)
+cpack_add_component(documentation
+ DISPLAY_NAME "MyLib Documentation"
+ DESCRIPTION "The extensive suite of MyLib Application documentation files"
+ GROUP Runtime
+ INSTALL_TYPES Full)
cpack_add_component(libraries
DISPLAY_NAME "Libraries"
DESCRIPTION "Static libraries used to build programs with MyLib"