summaryrefslogtreecommitdiffstats
path: root/Tests/CheckSourceTree/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CheckSourceTree/CMakeLists.txt')
-rw-r--r--Tests/CheckSourceTree/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/CheckSourceTree/CMakeLists.txt b/Tests/CheckSourceTree/CMakeLists.txt
new file mode 100644
index 0000000..d5019d2
--- /dev/null
+++ b/Tests/CheckSourceTree/CMakeLists.txt
@@ -0,0 +1,6 @@
+add_test(NAME CMake.CheckSourceTree
+ COMMAND ${CMAKE_COMMAND} -D GIT_EXECUTABLE=${GIT_EXECUTABLE}
+ -D CMake_SOURCE_DIR=${CMake_SOURCE_DIR}
+ -P ${CMAKE_CURRENT_LIST_DIR}/check.cmake
+ )
+set_property(TEST CMake.CheckSourceTree PROPERTY RUN_SERIAL 1)