summaryrefslogtreecommitdiffstats
path: root/Tests/CompileCommandOutput/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CompileCommandOutput/CMakeLists.txt')
-rw-r--r--Tests/CompileCommandOutput/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/Tests/CompileCommandOutput/CMakeLists.txt b/Tests/CompileCommandOutput/CMakeLists.txt
index ac39b8b..bd8e305 100644
--- a/Tests/CompileCommandOutput/CMakeLists.txt
+++ b/Tests/CompileCommandOutput/CMakeLists.txt
@@ -4,7 +4,12 @@ project (CompileCommandOutput CXX)
SET(CMAKE_EXPORT_COMPILE_COMMANDS ON)
set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
-ADD_LIBRARY(test1 STATIC "file with spaces.cxx")
+IF(MAKE_SUPPORTS_SPACES)
+ SET(test1_srcs "file with spaces.cxx")
+ELSE()
+ SET(test1_srcs "file_with_underscores.cxx")
+ENDIF()
+ADD_LIBRARY(test1 STATIC ${test1_srcs})
ADD_LIBRARY(test2 SHARED "../CompileCommandOutput/relative.cxx")
INCLUDE_DIRECTORIES(${CompileCommandOutput_SOURCE_DIR}/../../Source)
ADD_EXECUTABLE(CompileCommandOutput compile_command_output.cxx)