summaryrefslogtreecommitdiffstats
path: root/Tests/Complex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Complex/CMakeLists.txt')
-rw-r--r--Tests/Complex/CMakeLists.txt10
1 files changed, 3 insertions, 7 deletions
diff --git a/Tests/Complex/CMakeLists.txt b/Tests/Complex/CMakeLists.txt
index deb0800..88acae8 100644
--- a/Tests/Complex/CMakeLists.txt
+++ b/Tests/Complex/CMakeLists.txt
@@ -137,13 +137,9 @@ SET(FORCE_TEST 0 CACHE STRING "a test" FORCE)
#
# Lib and exe path
#
-SET (LIBRARY_OUTPUT_PATH
- ${Complex_BINARY_DIR}/bin/ CACHE INTERNAL
- "Single output directory for building all libraries.")
-
-SET (EXECUTABLE_OUTPUT_PATH
- ${Complex_BINARY_DIR}/bin/ CACHE INTERNAL
- "Single output directory for building all executables.")
+SET(CMAKE_ARCHIVE_OUTPUT_DIRECTORY "${Complex_BINARY_DIR}/lib/static")
+SET(CMAKE_LIBRARY_OUTPUT_DIRECTORY "${Complex_BINARY_DIR}/lib")
+SET(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${Complex_BINARY_DIR}/bin")
MESSAGE (Test " " escape " " semi-colon " " \; \;)
#