summaryrefslogtreecommitdiffstats
path: root/Tests/Complex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Complex/CMakeLists.txt')
-rw-r--r--Tests/Complex/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Tests/Complex/CMakeLists.txt b/Tests/Complex/CMakeLists.txt
index 0549c6f..2d6de20 100644
--- a/Tests/Complex/CMakeLists.txt
+++ b/Tests/Complex/CMakeLists.txt
@@ -161,6 +161,20 @@ SET(removeVar1 c e)
REMOVE(REMOVE_STRING ${removeVar1} f)
#
+# Test an IF inside a FOREACH.
+#
+FOREACH(x "a")
+ IF(1)
+ # Should always execute.
+ SET(IF_INSIDE_FOREACH_THEN_EXECUTED 1)
+ ELSE(1)
+ # Should never execute.
+ SET(IF_INSIDE_FOREACH_ELSE_EXECUTED 1)
+ ENDIF(1)
+ENDFOREACH(x)
+
+
+#
# Configure file
# (plug vars to #define so that they can be tested)
#