summaryrefslogtreecommitdiffstats
path: root/Tests/Complex/Library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Complex/Library/CMakeLists.txt')
-rw-r--r--Tests/Complex/Library/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/Tests/Complex/Library/CMakeLists.txt b/Tests/Complex/Library/CMakeLists.txt
index aaa11ca..1445ccc 100644
--- a/Tests/Complex/Library/CMakeLists.txt
+++ b/Tests/Complex/Library/CMakeLists.txt
@@ -8,10 +8,15 @@ ADD_EXECUTABLE(create_file create_file.cxx)
#
# Create static library
-# SOURCE_FILES_REMOVE is used for Coverage
+# SOURCE_FILES_REMOVE is used for Coverage. empty.h is included for coverage
#
AUX_SOURCE_DIRECTORY(ExtraSources LibrarySources)
-SOURCE_FILES(LibrarySources file2 create_file.cxx GENERATED nonexisting_file)
+SOURCE_FILES(LibrarySources
+ file2
+ empty
+ create_file.cxx
+ GENERATED
+ nonexisting_file)
SOURCE_FILES_REMOVE(LibrarySources create_file.cxx GENERATED nonexisting_file)
ADD_LIBRARY(CMakeTestLibrary LibrarySources)