summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
new file mode 100644
index 0000000..c11a47b
--- /dev/null
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -0,0 +1,26 @@
+# a simple test case
+PROJECT (Complex)
+
+ADD_DEFINITIONS(-DCMAKE_IS_FUN)
+SUBDIRS(Library Executable)
+SUBDIR_DEPENDS(Executable Library)
+
+INCLUDE(${Complex_SOURCE_DIR}/VarTests.txt)
+
+CONFIGURE_FILE(
+${Complex_SOURCE_DIR}/cmTestConfigure.h.in
+${Complex_BINARY_DIR}/cmTestConfigure.h)
+
+INCLUDE_DIRECTORIES(
+${Complex_BINARY_DIR}
+${Complex_SOURCE_DIR}/Library
+${Complex_SOURCE_DIR}/../../Source
+)
+LINK_DIRECTORIES(
+${Complex_BINARY_DIR}/Library
+)
+
+INCLUDE_REGULAR_EXPRESSION("^(cmTest|file|sharedFile).*$")
+
+SET (LIBRARY_OUTPUT_PATH ${Complex_BINARY_DIR}/bin/ CACHE PATH "Single output directory for building all libraries.")
+SET (EXECUTABLE_OUTPUT_PATH ${Complex_BINARY_DIR}/bin/ CACHE PATH "Single output directory for building all executables.")