summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Executable/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexOneConfig/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Executable/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/Tests/ComplexOneConfig/Executable/CMakeLists.txt b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
index 8efa373..86fb7a5 100644
--- a/Tests/ComplexOneConfig/Executable/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
@@ -13,9 +13,12 @@ IF(COMPLEX_TEST_CMAKELIB)
LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmexpat)
LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmzlib)
# prefer the new curl if it is around
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmcurl)
- ENDIF(CMAKE_USE_NEW_CURL)
+ IF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0)
+ LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0)
+ ENDIF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0)
+ IF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl)
+ LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmcurl)
+ ENDIF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl)
LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmtar)
ENDIF(COMPLEX_TEST_CMAKELIB)