summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Executable/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexOneConfig/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Executable/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/Tests/ComplexOneConfig/Executable/CMakeLists.txt b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
index f935aed..a8ab17b 100644
--- a/Tests/ComplexOneConfig/Executable/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
@@ -45,12 +45,8 @@ add_executable(complex.file complex.file.cxx complex_nobuild.cxx
if (UNIX)
target_link_libraries(complex ${CMAKE_DL_LIBS})
-else()
- if (NOT BORLAND)
- if(NOT MINGW)
- target_link_libraries(complex rpcrt4.lib)
- endif()
- endif()
+elseif(NOT BORLAND AND NOT MINGW AND NOT CMAKE_C_COMPILER_ID STREQUAL "OrangeC")
+ target_link_libraries(complex rpcrt4.lib)
endif ()
# Test linking to static lib when a shared lib has the same name.