summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexOneConfig/Library/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Library/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/Library/CMakeLists.txt b/Tests/ComplexOneConfig/Library/CMakeLists.txt
index c354c34..9feeb27 100644
--- a/Tests/ComplexOneConfig/Library/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Library/CMakeLists.txt
@@ -20,6 +20,17 @@ SOURCE_FILES(LibrarySources
SOURCE_FILES_REMOVE(LibrarySources create_file.cxx GENERATED nonexisting_file)
ADD_LIBRARY(CMakeTestLibrary LibrarySources)
+IF(WIN32)
+ IF(NOT CYGWIN)
+ TARGET_LINK_LIBRARIES(CMakeTestLibrary
+ debug
+ user32.lib)
+ TARGET_LINK_LIBRARIES(CMakeTestLibrary
+ optimized
+ kernel32.lib)
+ ENDIF(NOT CYGWIN)
+ENDIF(WIN32)
+
#
# Create shared library
#