summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexOneConfig/Library/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Library/CMakeLists.txt16
1 files changed, 3 insertions, 13 deletions
diff --git a/Tests/ComplexOneConfig/Library/CMakeLists.txt b/Tests/ComplexOneConfig/Library/CMakeLists.txt
index df874ef..9f2d5e1 100644
--- a/Tests/ComplexOneConfig/Library/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Library/CMakeLists.txt
@@ -23,19 +23,9 @@ set(LibrarySources ${LibrarySources}
remove(LibrarySources create_file.cxx GENERATED nonexisting_file)
add_library(CMakeTestLibrary ${LibrarySources})
-if(WIN32)
- if(NOT CYGWIN)
- if(NOT BORLAND)
- if(NOT MINGW)
- target_link_libraries(CMakeTestLibrary
- debug
- user32.lib)
- target_link_libraries(CMakeTestLibrary
- optimized
- kernel32.lib)
- endif()
- endif()
- endif()
+if(WIN32 AND NOT CYGWIN AND NOT BORLAND AND NOT MINGW)
+ target_link_libraries(CMakeTestLibrary debug user32.lib)
+ target_link_libraries(CMakeTestLibrary optimized kernel32.lib)
endif()
#