summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexOneConfig/Library/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Library/CMakeLists.txt26
1 files changed, 23 insertions, 3 deletions
diff --git a/Tests/ComplexOneConfig/Library/CMakeLists.txt b/Tests/ComplexOneConfig/Library/CMakeLists.txt
index 73f5ab4..473f2b3 100644
--- a/Tests/ComplexOneConfig/Library/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Library/CMakeLists.txt
@@ -1,24 +1,44 @@
AUX_SOURCE_DIRECTORY(ExtraSources LibrarySources)
-SOURCE_FILES(LibrarySources file2)
+# SOURCE_FILES_REMOVE is used for Coverage
+SOURCE_FILES(LibrarySources file2 GENERATED create_file.cxx)
+SOURCE_FILES_REMOVE(LibrarySources create_file.cxx)
ADD_LIBRARY(CMakeTestLibrary LibrarySources)
SOURCE_FILES(SharedLibrarySources sharedFile)
ADD_LIBRARY(CMakeTestLibraryShared SHARED SharedLibrarySources)
+#
+# Small utility used to create file
+#
UTILITY_SOURCE(CREATE_FILE_EXE create_file "." create_file.cxx)
ADD_EXECUTABLE(create_file create_file.cxx)
-ADD_DEPENDENCIES(CMakeTestLibraryShared create_file)
-
+#
# Attach a post-build custom-command to the lib.
# It run ${CREATE_FILE_EXE} which will create the file
# ${Complex_BINARY_DIR}/postbuild.txt.
# The 'complex' executable will then test if this file exists,
# and remove it.
+#
+ADD_DEPENDENCIES(CMakeTestLibraryShared create_file)
ADD_CUSTOM_COMMAND(SOURCE CMakeTestLibraryShared
COMMAND ${CREATE_FILE_EXE}
ARGS "${Complex_BINARY_DIR}/postbuild.txt"
TARGET CMakeTestLibraryShared)
+#
+# Add custom target
+# It run ${CREATE_FILE_EXE} which will create the file
+# ${Complex_BINARY_DIR}/custom_target1.txt.
+# The 'complex' executable will then test if this file exists,
+# and remove it.
+#
+ADD_CUSTOM_TARGET(custom_target1
+ ALL
+ ${CREATE_FILE_EXE}
+ "${Complex_BINARY_DIR}/custom_target1.txt")
+
+ADD_DEPENDENCIES(custom_target1 create_file)
+