summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexRelativePaths/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/Executable/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/Tests/ComplexRelativePaths/Executable/CMakeLists.txt b/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
index f0df86f..4bd1620 100644
--- a/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
@@ -1,4 +1,20 @@
ADD_EXECUTABLE(complex complex)
+
TARGET_LINK_LIBRARIES(complex CMakeTestLibrary)
TARGET_LINK_LIBRARIES(complex CMakeTestLibraryShared)
+FIND_LIBRARY(CMAKE_LIB
+ CMakeLib
+ ${Complex_BINARY_DIR}/../../Source
+ ${Complex_BINARY_DIR}/../../Source/Debug
+ ${Complex_BINARY_DIR}/../../Source/Release
+ ${Complex_BINARY_DIR}/../../Source/MinSizeRel
+ ${Complex_BINARY_DIR}/../../Source/RelWithDebInfo)
+
+TARGET_LINK_LIBRARIES(complex ${CMAKE_LIB})
+LINK_LIBRARIES(${CMAKE_LIB})
+
+# More coverage
+
+INSTALL_TARGETS(/tmp complex)
+INSTALL_PROGRAMS(/tmp complex)