summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexRelativePaths/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/Executable/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/Tests/ComplexRelativePaths/Executable/CMakeLists.txt b/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
index 1533f3e..165e7cd 100644
--- a/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
@@ -1,9 +1,10 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 1.3)
#
# Create exe.
#
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DTEST_CXX_FLAGS")
-SET_SOURCE_FILES_PROPERTIES(complex
- COMPILE_FLAGS "-DFILE_HAS_EXTRA_COMPILE_FLAGS")
+SET_SOURCE_FILES_PROPERTIES(complex COMPILE_FLAGS
+ "-DFILE_HAS_EXTRA_COMPILE_FLAGS")
ADD_EXECUTABLE(complex complex)
SET(COMPLEX_LIBS CMakeTestLibrary;CMakeTestLibraryShared;CMakeTestCLibraryShared)
@@ -19,7 +20,7 @@ LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Source)
TARGET_LINK_LIBRARIES(complex
CMakeLib
debug CMakeLib
- optimized CMakeLib)
+ optimized CgMakeLib)
#
# Output the files required by 'complex' to a file.
@@ -36,4 +37,8 @@ SUBDIRS(Temp)
INSTALL_TARGETS(/tmp complex)
INSTALL_PROGRAMS(/tmp complex)
+CONFIGURE_FILE(
+ ${Complex_SOURCE_DIR}/Executable/cmVersion.h.in
+ ${Complex_BINARY_DIR}/cmVersion.h)
+
SOURCE_GROUP(A_GROUP ".cxx")