summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ComplexRelativePaths/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/Executable/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/ComplexRelativePaths/Executable/CMakeLists.txt b/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
index 33332eb..438808f 100644
--- a/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
@@ -17,7 +17,11 @@ FIND_LIBRARY(CMAKE_LIB
${Complex_BINARY_DIR}/../../Source/MinSizeRel
${Complex_BINARY_DIR}/../../Source/RelWithDebInfo)
-TARGET_LINK_LIBRARIES(complex ${CMAKE_LIB})
+# Specify the same one for debug/optimized to increase coverage
+TARGET_LINK_LIBRARIES(complex
+ ${CMAKE_LIB}
+ debug ${CMAKE_LIB}
+ optimized ${CMAKE_LIB})
#
# Output the files required by 'complex' to a file.