summaryrefslogtreecommitdiffstats
path: root/Tests/Cuda/Toolkit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Cuda/Toolkit/CMakeLists.txt')
-rw-r--r--Tests/Cuda/Toolkit/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/Cuda/Toolkit/CMakeLists.txt b/Tests/Cuda/Toolkit/CMakeLists.txt
index 4255b82..08ba20a 100644
--- a/Tests/Cuda/Toolkit/CMakeLists.txt
+++ b/Tests/Cuda/Toolkit/CMakeLists.txt
@@ -70,7 +70,11 @@ foreach (cuda_lib IN LISTS npp_libs)
endif()
endforeach()
-foreach (cuda_lib nvrtc nvToolsExt OpenCL)
+set(nv_libs nvrtc OpenCL)
+if(CUDAToolkit_VERSION_MAJOR VERSION_LESS 12)
+ list(APPEND nv_libs nvToolsExt)
+endif()
+foreach (cuda_lib IN LISTS nv_libs)
if(NOT TARGET CUDA::${cuda_lib})
message(FATAL_ERROR "The CUDA::${cuda_lib} target was expected but couldn't be found")
endif()