summaryrefslogtreecommitdiffstats
path: root/Tests/Cuda/Toolkit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Cuda/Toolkit/CMakeLists.txt')
-rw-r--r--Tests/Cuda/Toolkit/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/Tests/Cuda/Toolkit/CMakeLists.txt b/Tests/Cuda/Toolkit/CMakeLists.txt
index 8432b71..c2989f0 100644
--- a/Tests/Cuda/Toolkit/CMakeLists.txt
+++ b/Tests/Cuda/Toolkit/CMakeLists.txt
@@ -26,9 +26,11 @@ set(should_exist
CUDAToolkit_LIBRARY_ROOT
)
foreach (cuda_loc_var IN LISTS should_exist)
- if(NOT EXISTS "${${cuda_loc_var}}")
- message(FATAL_ERROR "${cuda_loc_var} variable is expected to be set to valid path")
- endif()
+ foreach (entry IN LISTS ${cuda_loc_var})
+ if(NOT EXISTS "${entry}")
+ message(FATAL_ERROR "${cuda_loc_var} variable is expected to be set to valid path")
+ endif()
+ endforeach()
endforeach()