summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CustomCommand/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/CustomCommand/CMakeLists.txt b/Tests/CustomCommand/CMakeLists.txt
index 53d56bf..c1a7a57 100644
--- a/Tests/CustomCommand/CMakeLists.txt
+++ b/Tests/CustomCommand/CMakeLists.txt
@@ -514,6 +514,14 @@ add_custom_target(UseConsoleTarget ALL
USES_TERMINAL
)
+if(CMAKE_XCODE_BUILD_SYSTEM VERSION_GREATER_EQUAL 12)
+ # Xcode's "new build system" does not support multiple targets
+ # producing the same custom command output.
+ add_custom_target(GenPath DEPENDS "${gen_path}")
+ add_dependencies(NormDepends GenPath)
+ add_dependencies(UseConsole GenPath)
+endif()
+
# Test COMMAND_EXPAND_LISTS
set(cmp_args "1ARG=COMMAND_EXPAND_LISTS" "2ARG=test" "3ARG=outfile"
"4ARG=content")