summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommand/GeneratorInExtraDir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CustomCommand/GeneratorInExtraDir/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/GeneratorInExtraDir/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CustomCommand/GeneratorInExtraDir/CMakeLists.txt b/Tests/CustomCommand/GeneratorInExtraDir/CMakeLists.txt
index e838e7b..195a477 100644
--- a/Tests/CustomCommand/GeneratorInExtraDir/CMakeLists.txt
+++ b/Tests/CustomCommand/GeneratorInExtraDir/CMakeLists.txt
@@ -1,3 +1,5 @@
+ADD_DEFINITIONS(-DGENERATOR_EXTERN)
+
# add the executable which will be used for generating files
ADD_EXECUTABLE(generator_extern ../generator.cxx)
SET_TARGET_PROPERTIES(generator_extern PROPERTIES OUTPUT_NAME the_external_generator)