summaryrefslogtreecommitdiffstats
path: root/Tests/CxxOnly/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CxxOnly/CMakeLists.txt')
-rw-r--r--Tests/CxxOnly/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/CxxOnly/CMakeLists.txt b/Tests/CxxOnly/CMakeLists.txt
index 0b2c1c5..5d27890 100644
--- a/Tests/CxxOnly/CMakeLists.txt
+++ b/Tests/CxxOnly/CMakeLists.txt
@@ -2,7 +2,10 @@
project (CxxOnly CXX)
set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
-add_library(testcxx1.my STATIC libcxx1.cxx test.CPP)
+if(WIN32)
+ set(EXTRA_SRCS test.CPP)
+endif()
+add_library(testcxx1.my STATIC libcxx1.cxx ${EXTRA_SRCS})
add_library(testcxx2 SHARED libcxx2.cxx)
add_executable (CxxOnly cxxonly.cxx)
target_link_libraries(CxxOnly testcxx1.my testcxx2)