summaryrefslogtreecommitdiffstats
path: root/Tests/Dependency/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Dependency/CMakeLists.txt')
-rw-r--r--Tests/Dependency/CMakeLists.txt34
1 files changed, 16 insertions, 18 deletions
diff --git a/Tests/Dependency/CMakeLists.txt b/Tests/Dependency/CMakeLists.txt
index 3f2bee8..b7debc6 100644
--- a/Tests/Dependency/CMakeLists.txt
+++ b/Tests/Dependency/CMakeLists.txt
@@ -1,27 +1,25 @@
PROJECT( Dependency )
-SET( LIBRARY_OUTPUT_PATH ${Dependency_BINARY_DIR}/Lib )
-SET( CMAKE_ANALYZE_LIB_DEPENDS "ON" )
-
# There is one executable that depends on eight libraries. The
# system has the following dependency graph:
#
-# +----------- NoDepC <---- EXECUTABLE
-# | | |
-# V | |
-# | |
-# NoDepA <----- NoDepB <-------+ |
-# |
-# ^ |
+# +----------- NoDepC <---- EXECUTABLE ---+
+# | | | |
+# V | | |
+# | | |
+# NoDepA <----- NoDepB <-------+ | |
+# | |
+# ^ | V
# | |
-# One <------ Four -----> Two <----- Five <---+
-# |
-# ^ ^ ^ | ^ ^ ^
-# | | +-----+ | | | +----+
-# | | | | | | |
-# +--------- Three <------+ +------- SixA SixB
-# | |
-# +-----------------------+
+# One <------ Four -----> Two <----- Five <---|----- SixB
+# | | |
+# ^ ^ ^ | ^ ^ | |
+# | | +-----+ | \ | | |
+# | | | | \ | | |
+# +--------- Three <------+ --- SixA <----+ |
+# | |
+# | |
+# +---------------------------------+
# NoDepA:
# NoDepB: NoDepA
# NoDepC: NoDepA