summaryrefslogtreecommitdiffstats
path: root/Tests/FindBLAS/Test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FindBLAS/Test/CMakeLists.txt')
-rw-r--r--Tests/FindBLAS/Test/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/FindBLAS/Test/CMakeLists.txt b/Tests/FindBLAS/Test/CMakeLists.txt
index 59418f3..1bebf8e 100644
--- a/Tests/FindBLAS/Test/CMakeLists.txt
+++ b/Tests/FindBLAS/Test/CMakeLists.txt
@@ -11,3 +11,9 @@ add_test(NAME test_tgt COMMAND test_tgt)
add_executable(test_var main.c)
target_link_libraries(test_var PRIVATE ${BLAS_LIBRARIES})
add_test(NAME test_var COMMAND test_var)
+
+if(BLA_VENDOR STREQUAL "Intel10_64lp")
+ if(NOT BLAS_LIBRARIES MATCHES "^[^;]*mkl_intel_lp64")
+ message(FATAL_ERROR "BLAS_LIBRARIES does not start in mkl_intel_lp64:\n ${BLAS_LIBRARIES}")
+ endif()
+endif()