summaryrefslogtreecommitdiffstats
path: root/Tests/FindBoost/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FindBoost/CMakeLists.txt')
-rw-r--r--Tests/FindBoost/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/FindBoost/CMakeLists.txt b/Tests/FindBoost/CMakeLists.txt
index 58d795b..8489d85 100644
--- a/Tests/FindBoost/CMakeLists.txt
+++ b/Tests/FindBoost/CMakeLists.txt
@@ -21,7 +21,8 @@ add_test(NAME FindBoost.TestFail COMMAND
)
set_tests_properties(FindBoost.TestFail PROPERTIES
- PASS_REGULAR_EXPRESSION "Could not find the following Boost libraries:[ \t\n]+boost_foobar")
+ WILL_FAIL ON
+ PASS_REGULAR_EXPRESSION "Could NOT find Boost (missing: foobar)")
add_test(NAME FindBoost.TestHeaders COMMAND
${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>