summaryrefslogtreecommitdiffstats
path: root/Tests/FindPython/Python2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FindPython/Python2/CMakeLists.txt')
-rw-r--r--Tests/FindPython/Python2/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/FindPython/Python2/CMakeLists.txt b/Tests/FindPython/Python2/CMakeLists.txt
index 9622b6f..c5da3b1 100644
--- a/Tests/FindPython/Python2/CMakeLists.txt
+++ b/Tests/FindPython/Python2/CMakeLists.txt
@@ -14,6 +14,14 @@ if (NOT Python2_FOUND)
message (FATAL_ERROR "Fail to found Python 2")
endif()
+if(NOT TARGET Python2::Interpreter)
+ message(SEND_ERROR "Python2::Interpreter not found")
+endif()
+
+if(NOT TARGET Python2::Python)
+ message(SEND_ERROR "Python2::Python not found")
+endif()
+
Python2_add_library (spam2 MODULE ../spam.c)
target_compile_definitions (spam2 PRIVATE PYTHON2)