summaryrefslogtreecommitdiffstats
path: root/Tests/FindPython/Python3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FindPython/Python3/CMakeLists.txt')
-rw-r--r--Tests/FindPython/Python3/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/FindPython/Python3/CMakeLists.txt b/Tests/FindPython/Python3/CMakeLists.txt
index cb86eae..eb3ad79 100644
--- a/Tests/FindPython/Python3/CMakeLists.txt
+++ b/Tests/FindPython/Python3/CMakeLists.txt
@@ -14,6 +14,14 @@ if (NOT Python3_FOUND)
message (FATAL_ERROR "Fail to found Python 3")
endif()
+if(NOT TARGET Python3::Interpreter)
+ message(SEND_ERROR "Python2::Interpreter not found")
+endif()
+
+if(NOT TARGET Python3::Python)
+ message(SEND_ERROR "Python2::Python not found")
+endif()
+
Python3_add_library (spam3 MODULE ../spam.c)
target_compile_definitions (spam3 PRIVATE PYTHON3)