summaryrefslogtreecommitdiffstats
path: root/Tests/FortranC/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FortranC/CMakeLists.txt')
-rw-r--r--Tests/FortranC/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/FortranC/CMakeLists.txt b/Tests/FortranC/CMakeLists.txt
index e4e8ca1..12d4165 100644
--- a/Tests/FortranC/CMakeLists.txt
+++ b/Tests/FortranC/CMakeLists.txt
@@ -13,11 +13,11 @@ file(REMOVE_RECURSE ${CMAKE_BINARY_DIR}/CMakeFiles/FortranCInterface)
if(FortranC_TEST_FLAGS)
# Test whether FortranCInterface checks see C flags.
- set(ENV{TEST_OPT_CC} "--test-opt-cc")
+ set(ENV{TEST_OPT_CC} "--test-opt-cc=1")
set(CMAKE_C_FLAGS "$ENV{TEST_OPT_CC}")
# Test whether FortranCInterface checks see Fortran flags.
- set(ENV{TEST_OPT_FC} "--test-opt-fc")
+ set(ENV{TEST_OPT_FC} "--test-opt-fc=1")
set(CMAKE_Fortran_FLAGS "$ENV{TEST_OPT_FC}")
endif()