summaryrefslogtreecommitdiffstats
path: root/Tests/FortranC/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FortranC/CMakeLists.txt')
-rw-r--r--Tests/FortranC/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/FortranC/CMakeLists.txt b/Tests/FortranC/CMakeLists.txt
index 12d4165..f335583 100644
--- a/Tests/FortranC/CMakeLists.txt
+++ b/Tests/FortranC/CMakeLists.txt
@@ -14,11 +14,11 @@ file(REMOVE_RECURSE ${CMAKE_BINARY_DIR}/CMakeFiles/FortranCInterface)
if(FortranC_TEST_FLAGS)
# Test whether FortranCInterface checks see C flags.
set(ENV{TEST_OPT_CC} "--test-opt-cc=1")
- set(CMAKE_C_FLAGS "$ENV{TEST_OPT_CC}")
+ set(CMAKE_C_FLAGS "$ENV{TEST_OPT_CC} ${CMAKE_C_FLAGS}")
# Test whether FortranCInterface checks see Fortran flags.
set(ENV{TEST_OPT_FC} "--test-opt-fc=1")
- set(CMAKE_Fortran_FLAGS "$ENV{TEST_OPT_FC}")
+ set(CMAKE_Fortran_FLAGS "$ENV{TEST_OPT_FC} ${CMAKE_Fortran_FLAGS}")
endif()
include(FortranCInterface)