summaryrefslogtreecommitdiffstats
path: root/Tests/Framework/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Framework/CMakeLists.txt')
-rw-r--r--Tests/Framework/CMakeLists.txt41
1 files changed, 33 insertions, 8 deletions
diff --git a/Tests/Framework/CMakeLists.txt b/Tests/Framework/CMakeLists.txt
index 8264505..f1f82cb 100644
--- a/Tests/Framework/CMakeLists.txt
+++ b/Tests/Framework/CMakeLists.txt
@@ -1,11 +1,29 @@
project(Framework)
-add_library(foo SHARED foo.cxx foo.h)
+add_library(foo SHARED
+ foo.cxx
+ foo.h
+ foo2.h
+ fooPublic.h
+ fooPrivate.h
+ fooNeither.h
+ fooBoth.h
+ test.lua
+)
set_target_properties(foo PROPERTIES
FRAMEWORK TRUE
- FRAMEWORK_PUBLIC_HEADERS "foo.h;foo2.h"
- FRAMEWORK_VERSION ver2
- FRAMEWORK_RESOURCES "test.lua"
+ FRAMEWORK_VERSION ver3
+)
+# fooNeither.h is marked neither public nor private...
+# fooBoth.h is marked both public and private... (private wins...)
+set_source_files_properties(foo.h foo2.h fooPublic.h fooBoth.h PROPERTIES
+ FRAMEWORK_PUBLIC_HEADER TRUE
+)
+set_source_files_properties(fooPrivate.h fooBoth.h PROPERTIES
+ FRAMEWORK_PRIVATE_HEADER TRUE
+)
+set_source_files_properties(test.lua PROPERTIES
+ FRAMEWORK_RESOURCE TRUE
)
add_executable(bar bar.cxx)
target_link_libraries(bar foo)
@@ -16,12 +34,19 @@ target_link_libraries(bar foo)
# a framework... The framework properties only apply when the library type
# is SHARED.
#
-add_library(fooStatic STATIC foo.cxx foo.h)
+add_library(fooStatic STATIC
+ foo.cxx
+ foo.h
+ foo2.h
+ fooPublic.h
+ fooPrivate.h
+ fooNeither.h
+ fooBoth.h
+ test.lua
+)
set_target_properties(fooStatic PROPERTIES
FRAMEWORK TRUE
- FRAMEWORK_PUBLIC_HEADERS "foo.h;foo2.h"
- FRAMEWORK_VERSION ver2
- FRAMEWORK_RESOURCES "test.lua"
+ FRAMEWORK_VERSION none
)
add_executable(barStatic bar.cxx)
target_link_libraries(barStatic fooStatic)