summaryrefslogtreecommitdiffstats
path: root/Tests/GhsMulti/GhsMultiCopyFile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/GhsMulti/GhsMultiCopyFile/CMakeLists.txt')
-rw-r--r--Tests/GhsMulti/GhsMultiCopyFile/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/Tests/GhsMulti/GhsMultiCopyFile/CMakeLists.txt b/Tests/GhsMulti/GhsMultiCopyFile/CMakeLists.txt
new file mode 100644
index 0000000..46d833b
--- /dev/null
+++ b/Tests/GhsMulti/GhsMultiCopyFile/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Distributed under the OSI-approved BSD 3-Clause License. See accompanying
+# file Copyright.txt or https://cmake.org/licensing for details.
+
+cmake_minimum_required(VERSION 3.12 FATAL_ERROR)
+
+project(test C)
+
+set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
+try_compile(RESULT
+ ${CMAKE_CURRENT_BINARY_DIR}/build
+ ${CMAKE_CURRENT_SOURCE_DIR}/test.c
+ CMAKE_FLAGS -DGHS_BSP_NAME=${GHS_BSP_NAME}
+ -DGHS_OS_ROOT=${GHS_OS_ROOT}
+ -DGHS_OS_DIR=${GHS_OS_DIR}
+ -DGHS_TOOLSET_ROOT=${GHS_TOOLSET_ROOT}
+ -DGHS_TARGET_PLATFORM=${GHS_TARGET_PLATFORM}
+ OUTPUT_VARIABLE OUTPUT
+ COPY_FILE "${CMAKE_CURRENT_BINARY_DIR}/test_library"
+)
+
+message(STATUS "Output from build:\n${OUTPUT}")
+
+if(NOT RESULT)
+ message(SEND_ERROR "try_compile() failed")
+endif()
+
+if(EXISTS "${CMAKE_CURRENT_BINARY_DIR}/test_library")
+ if (IS_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/test_library")
+ message(SEND_ERROR "library is folder !")
+ else()
+ message(STATUS "library seems okay")
+ endif()
+else()
+ message(SEND_ERROR "library is not found !")
+endif()