summaryrefslogtreecommitdiffstats
path: root/Tests/GhsMulti/GhsMultiExclude/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/GhsMulti/GhsMultiExclude/CMakeLists.txt')
-rw-r--r--Tests/GhsMulti/GhsMultiExclude/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/GhsMulti/GhsMultiExclude/CMakeLists.txt b/Tests/GhsMulti/GhsMultiExclude/CMakeLists.txt
new file mode 100644
index 0000000..329cb3f
--- /dev/null
+++ b/Tests/GhsMulti/GhsMultiExclude/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Distributed under the OSI-approved BSD 3-Clause License. See accompanying
+# file Copyright.txt or https://cmake.org/licensing for details.
+
+cmake_minimum_required(VERSION 3.12 FATAL_ERROR)
+
+project(test C)
+
+add_library(lib1 lib1.c)
+set_target_properties( lib1 PROPERTIES EXCLUDE_FROM_ALL yes )
+
+add_library(lib2 EXCLUDE_FROM_ALL lib1.c)
+
+add_executable(exe1 exe1.c)