summaryrefslogtreecommitdiffstats
path: root/Tests/GhsMulti/GhsMultiLinkTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/GhsMulti/GhsMultiLinkTest/CMakeLists.txt')
-rw-r--r--Tests/GhsMulti/GhsMultiLinkTest/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/Tests/GhsMulti/GhsMultiLinkTest/CMakeLists.txt b/Tests/GhsMulti/GhsMultiLinkTest/CMakeLists.txt
index da80b51..2d21bfb 100644
--- a/Tests/GhsMulti/GhsMultiLinkTest/CMakeLists.txt
+++ b/Tests/GhsMulti/GhsMultiLinkTest/CMakeLists.txt
@@ -38,8 +38,7 @@ if (RUN_TEST STREQUAL "NO_FLAGS")
else()
unset(fileName CACHE)
find_file(fileName exe1.gpj
- ${CMAKE_CURRENT_BINARY_DIR}/link_build
- ${CMAKE_CURRENT_BINARY_DIR}/link_build/exe1
+ ${CMAKE_CURRENT_BINARY_DIR}/link_build/exe1.dir
)
message("Parsing project file: ${fileName}")
file(STRINGS ${fileName} fileText)
@@ -54,13 +53,14 @@ else()
string(FIND "${fileText}" "${opt}" opt_found)
if ( opt_found EQUAL -1 )
message(SEND_ERROR "Could not find: ${opt}")
+ else()
+ message("located: ${opt}")
endif()
endforeach()
unset(fileName CACHE)
find_file (fileName lib1.gpj
- ${CMAKE_CURRENT_BINARY_DIR}/link_build
- ${CMAKE_CURRENT_BINARY_DIR}/link_build/lib1
+ ${CMAKE_CURRENT_BINARY_DIR}/link_build/lib1.dir
)
message("Parsing project file: ${fileName}")
file(STRINGS ${fileName} fileText)
@@ -71,13 +71,14 @@ else()
string(FIND "${fileText}" "${opt}" opt_found)
if (opt_found EQUAL -1)
message(SEND_ERROR "Could not find: ${opt}")
+ else()
+ message("located: ${opt}")
endif()
endforeach()
unset(fileName CACHE)
find_file (fileName lib2.gpj
- ${CMAKE_CURRENT_BINARY_DIR}/link_build
- ${CMAKE_CURRENT_BINARY_DIR}/link_build/lib2
+ ${CMAKE_CURRENT_BINARY_DIR}/link_build/lib2.dir
)
message("Parsing project file: ${fileName}")
file(STRINGS ${fileName} fileText)
@@ -87,6 +88,8 @@ else()
string(FIND "${fileText}" "${opt}" opt_found)
if ( opt_found EQUAL -1 )
message(SEND_ERROR "Could not find: ${opt}")
+ else()
+ message("located: ${opt}")
endif()
endforeach()
endif()