summaryrefslogtreecommitdiffstats
path: root/Tests/HIP/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/HIP/CMakeLists.txt')
-rw-r--r--Tests/HIP/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/HIP/CMakeLists.txt b/Tests/HIP/CMakeLists.txt
index 9499be8..26d7459 100644
--- a/Tests/HIP/CMakeLists.txt
+++ b/Tests/HIP/CMakeLists.txt
@@ -9,7 +9,10 @@ add_hip_test_macro(HIP.CompileFlags HIPOnlyCompileFlags)
add_hip_test_macro(HIP.EnableStandard HIPEnableStandard)
add_hip_test_macro(HIP.InferHipLang1 HIPInferHipLang1)
add_hip_test_macro(HIP.InferHipLang2 HIPInferHipLang2)
-add_hip_test_macro(HIP.MathFunctions HIPOnlyMathFunctions)
+if(CMake_TEST_HIP STREQUAL "amd")
+ # The NVIDIA CUDA compiler cannot handle device lambda markup.
+ add_hip_test_macro(HIP.MathFunctions HIPOnlyMathFunctions)
+endif()
add_hip_test_macro(HIP.MixedLanguage HIPMixedLanguage)
add_hip_test_macro(HIP.TryCompile HIPOnlyTryCompile)
add_hip_test_macro(HIP.WithDefs HIPOnlyWithDefs)