summaryrefslogtreecommitdiffstats
path: root/Tests/InterfaceBuildTargets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/InterfaceBuildTargets/CMakeLists.txt')
-rw-r--r--Tests/InterfaceBuildTargets/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/InterfaceBuildTargets/CMakeLists.txt b/Tests/InterfaceBuildTargets/CMakeLists.txt
new file mode 100644
index 0000000..a00e5d5
--- /dev/null
+++ b/Tests/InterfaceBuildTargets/CMakeLists.txt
@@ -0,0 +1,13 @@
+project(InterfaceBuildTargets)
+
+add_library(testlib EXCLUDE_FROM_ALL testlib.cxx)
+set_property(TARGET testlib PROPERTY PREFIX "")
+if(CMAKE_GENERATOR MATCHES "Borland|Watcom")
+ # These librarians add the .lib suffix anyway.
+ set_property(TARGET testlib PROPERTY SUFFIX ".lib")
+else()
+ set_property(TARGET testlib PROPERTY SUFFIX "")
+endif()
+
+add_library(iface INTERFACE)
+target_link_libraries(iface INTERFACE testlib)