summaryrefslogtreecommitdiffstats
path: root/Tests/LinkLine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/LinkLine/CMakeLists.txt')
-rw-r--r--Tests/LinkLine/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/LinkLine/CMakeLists.txt b/Tests/LinkLine/CMakeLists.txt
new file mode 100644
index 0000000..6154dd4
--- /dev/null
+++ b/Tests/LinkLine/CMakeLists.txt
@@ -0,0 +1,12 @@
+project( LinkLine )
+
+# Makes sure that the library order as specified by the user are
+# unchanged by dependency analysis, etc. libOne and libTwo are
+# dependent on each other. The link line should be -lOne -lTwo -lOne.
+
+add_library( One One.c )
+add_library( Two Two.c )
+
+link_libraries( One Two )
+add_executable( LinkLine Exec.c )
+link_libraries( One )