summaryrefslogtreecommitdiffstats
path: root/Tests/LinkStatic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/LinkStatic/CMakeLists.txt')
-rw-r--r--Tests/LinkStatic/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/LinkStatic/CMakeLists.txt b/Tests/LinkStatic/CMakeLists.txt
index 2062c43..200d4e5 100644
--- a/Tests/LinkStatic/CMakeLists.txt
+++ b/Tests/LinkStatic/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.8.4.20110303 FATAL_ERROR)
project(LinkStatic C)
-if(NOT "${CMAKE_C_COMPILER_ID}" MATCHES "^(GNU)$")
+if(NOT CMAKE_C_COMPILER_ID STREQUAL "GNU")
message(FATAL_ERROR "This test works only with the GNU compiler!")
endif()