summaryrefslogtreecommitdiffstats
path: root/Tests/LinkStatic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/LinkStatic/CMakeLists.txt')
-rw-r--r--Tests/LinkStatic/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/LinkStatic/CMakeLists.txt b/Tests/LinkStatic/CMakeLists.txt
index 200d4e5..60a270b 100644
--- a/Tests/LinkStatic/CMakeLists.txt
+++ b/Tests/LinkStatic/CMakeLists.txt
@@ -1,8 +1,8 @@
cmake_minimum_required(VERSION 2.8.4.20110303 FATAL_ERROR)
project(LinkStatic C)
-if(NOT CMAKE_C_COMPILER_ID STREQUAL "GNU")
- message(FATAL_ERROR "This test works only with the GNU compiler!")
+if(NOT CMAKE_C_COMPILER_ID MATCHES "GNU|LCC")
+ message(FATAL_ERROR "This test works only with the GNU or LCC compiler!")
endif()
find_library(MATH_LIBRARY NAMES libm.a)