summaryrefslogtreecommitdiffstats
path: root/Tests/MSManifest/Subdir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/MSManifest/Subdir/CMakeLists.txt')
-rw-r--r--Tests/MSManifest/Subdir/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/Tests/MSManifest/Subdir/CMakeLists.txt b/Tests/MSManifest/Subdir/CMakeLists.txt
index 11272bb..8664572 100644
--- a/Tests/MSManifest/Subdir/CMakeLists.txt
+++ b/Tests/MSManifest/Subdir/CMakeLists.txt
@@ -2,10 +2,9 @@ configure_file(test.manifest.in test.manifest)
add_executable(MSManifest main.c ${CMAKE_CURRENT_BINARY_DIR}/test.manifest)
if(MSVC AND NOT MSVC_VERSION LESS 1400)
- add_custom_command(TARGET MSManifest POST_BUILD VERBATIM
- COMMAND ${CMAKE_COMMAND} -Dexe=$<TARGET_FILE:MSManifest>
- -P ${CMAKE_CURRENT_SOURCE_DIR}/check.cmake
- )
+ add_test(NAME MSManifest.Single COMMAND
+ ${CMAKE_COMMAND} -Dexe=$<TARGET_FILE:MSManifest>
+ -P ${CMAKE_CURRENT_SOURCE_DIR}/check.cmake)
add_executable(MSManifestNone main.c)
set_property(TARGET MSManifestNone PROPERTY LINK_FLAGS "/MANIFEST:NO")
endif()