summaryrefslogtreecommitdiffstats
path: root/Tests/MSVCRuntimeLibrary/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/MSVCRuntimeLibrary/CMakeLists.txt')
-rw-r--r--Tests/MSVCRuntimeLibrary/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/MSVCRuntimeLibrary/CMakeLists.txt b/Tests/MSVCRuntimeLibrary/CMakeLists.txt
index 6994d8d..f7d9fec 100644
--- a/Tests/MSVCRuntimeLibrary/CMakeLists.txt
+++ b/Tests/MSVCRuntimeLibrary/CMakeLists.txt
@@ -2,6 +2,10 @@ cmake_minimum_required(VERSION 3.14)
cmake_policy(SET CMP0091 NEW)
project(MSVCRuntimeLibrary)
+if(CMake_TEST_CUDA)
+ enable_language(CUDA)
+endif()
+
function(verify_combinations threads lang src)
set(verify_tc_config_ Release)
set(verify_tc_config_Debug Debug)
@@ -62,3 +66,6 @@ endfunction()
verify(C verify.c)
verify(CXX verify.cxx)
+if(CMake_TEST_CUDA)
+ verify(CUDA verify.cu)
+endif()