summaryrefslogtreecommitdiffstats
path: root/Tests/MacRuntimePath/B/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/MacRuntimePath/B/CMakeLists.txt')
-rw-r--r--Tests/MacRuntimePath/B/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/Tests/MacRuntimePath/B/CMakeLists.txt b/Tests/MacRuntimePath/B/CMakeLists.txt
new file mode 100644
index 0000000..c361620
--- /dev/null
+++ b/Tests/MacRuntimePath/B/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 2.8)
+project(MacRuntimePath_B)
+
+include(${MacRuntimePath_B_BINARY_DIR}/../Root/lib/exp.cmake)
+
+add_executable(testb ${MacRuntimePath_B_SOURCE_DIR}/../A/test3.cpp)
+
+# test link with rpath enabled targets
+target_link_libraries(testb shared framework)
+
+# test link with rpath enabled library by filename
+target_link_libraries(testb $<TARGET_LINKER_FILE:shared2> framework)
+
+add_custom_target(testb_run ALL
+ COMMAND testb
+ DEPENDS testb
+ )