summaryrefslogtreecommitdiffstats
path: root/Tests/ModuleDefinition/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ModuleDefinition/CMakeLists.txt')
-rw-r--r--Tests/ModuleDefinition/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/ModuleDefinition/CMakeLists.txt b/Tests/ModuleDefinition/CMakeLists.txt
index 0cef0c7..b463a3c 100644
--- a/Tests/ModuleDefinition/CMakeLists.txt
+++ b/Tests/ModuleDefinition/CMakeLists.txt
@@ -5,10 +5,11 @@ project(ModuleDefinition C)
add_library(example_dll SHARED example_dll.c example_dll.def)
# Test /DEF:<file> flag recognition for VS.
-if(MSVC)
+if(MSVC OR "${CMAKE_C_COMPILER_ID}" MATCHES "^(Intel)$")
add_library(example_dll_2 SHARED example_dll_2.c)
set_property(TARGET example_dll_2 PROPERTY LINK_FLAGS
/DEF:"${ModuleDefinition_SOURCE_DIR}/example_dll_2.def")
+ set_property(DIRECTORY APPEND PROPERTY COMPILE_DEFINITIONS EXAMPLE_DLL_2)
set(example_dll_2 example_dll_2)
endif()