summaryrefslogtreecommitdiffstats
path: root/Tests/NewlineArgs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/NewlineArgs/CMakeLists.txt')
-rw-r--r--Tests/NewlineArgs/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/Tests/NewlineArgs/CMakeLists.txt b/Tests/NewlineArgs/CMakeLists.txt
new file mode 100644
index 0000000..d582639
--- /dev/null
+++ b/Tests/NewlineArgs/CMakeLists.txt
@@ -0,0 +1,15 @@
+# a simple CXX only test case
+project (newlineargs CXX)
+
+add_definitions("-DTEST_FLAG_1
+-DTEST_FLAG_2")
+
+include_directories("${newlineargs_BINARY_DIR}
+${newlineargs_SOURCE_DIR}")
+
+configure_file("${newlineargs_SOURCE_DIR}/libcxx2.h.in"
+ "${newlineargs_BINARY_DIR}/libcxx2.h")
+
+add_library(testcxx1 libcxx1.cxx)
+add_executable (cxxonly cxxonly.cxx)
+target_link_libraries(cxxonly testcxx1)