summaryrefslogtreecommitdiffstats
path: root/Tests/ObjectLibrary/A/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ObjectLibrary/A/CMakeLists.txt')
-rw-r--r--Tests/ObjectLibrary/A/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/Tests/ObjectLibrary/A/CMakeLists.txt b/Tests/ObjectLibrary/A/CMakeLists.txt
index c24c5ed..188fd64 100644
--- a/Tests/ObjectLibrary/A/CMakeLists.txt
+++ b/Tests/ObjectLibrary/A/CMakeLists.txt
@@ -12,11 +12,8 @@ add_custom_command(
)
# Remove the custom command output to be sure it runs in an
-# incremental test. Skip this on VS 6 because it sometimes
-# re-runs CMake after the custom command runs.
-if(NOT CMAKE_GENERATOR STREQUAL "Visual Studio 6")
- file(REMOVE ${CMAKE_CURRENT_BINARY_DIR}/a.cmake)
-endif()
+# incremental test.
+file(REMOVE ${CMAKE_CURRENT_BINARY_DIR}/a.cmake)
add_custom_command(
OUTPUT a.cmake
COMMAND ${CMAKE_COMMAND} -E touch ${CMAKE_CURRENT_BINARY_DIR}/a.cmake