summaryrefslogtreecommitdiffstats
path: root/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
index d418809..10a2f59 100644
--- a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
+++ b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
@@ -36,7 +36,7 @@ if ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
while("${DEEPDIR_LEN}" LESS "${MAXPATH}")
set(DEEPDIR ${DEEPDIR}/and/deeper)
string(LENGTH "${DEEPDIR}" DEEPDIR_LEN)
- endwhile("${DEEPDIR_LEN}" LESS "${MAXPATH}")
+ endwhile()
set(DEEPSRC ${DEEPDIR}/simple.cxx)
string(LENGTH "${DEEPSRC}" DEEPSRC_LEN)
configure_file(simple.cxx.in ${DEEPSRC} COPYONLY)
@@ -46,12 +46,12 @@ if ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
if(${CMAKE_GENERATOR} MATCHES "Watcom WMake")
set(DEEPSRC "")
add_definitions(-DNO_DEEPSRC)
- endif(${CMAKE_GENERATOR} MATCHES "Watcom WMake")
+ endif()
add_library(testlib testlib.cxx)
add_executable (simple simple.cxx ../simple.cxx ${DEEPSRC})
target_link_libraries(simple testlib outlib)
-endif ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
+endif ()
# test getting a definition from a subdir
set (WEASELS SIZZLING)
@@ -59,4 +59,4 @@ set (WEASELS SIZZLING)
get_directory_property(incDirs INCLUDE_DIRECTORIES)
if(NOT incDirs)
message(FATAL_ERROR "get_directory_property(INCLUDE_DIRECTORIES) returned empty list")
-endif(NOT incDirs)
+endif()