summaryrefslogtreecommitdiffstats
path: root/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
index d111509..175138b 100644
--- a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
+++ b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
@@ -21,13 +21,6 @@ IF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
MATH(EXPR MAXPATH "${MAXPATH} - 46")
ENDIF(${CMAKE_GENERATOR} MATCHES "Visual Studio 8")
- # Watcom WMake seems to have problems with long command lines. This
- # limit should still be big enough to require special object file name
- # conversion.
- IF(${CMAKE_GENERATOR} MATCHES "Watcom WMake")
- SET(MAXPATH 180)
- ENDIF(${CMAKE_GENERATOR} MATCHES "Watcom WMake")
-
# MAXPATH less 25 for last /and/deeper/simple.cxx part and small safety
MATH(EXPR MAXPATH "${MAXPATH} - 25")
STRING(LENGTH "${DEEPDIR}" DEEPDIR_LEN)
@@ -39,6 +32,13 @@ IF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
STRING(LENGTH "${DEEPSRC}" DEEPSRC_LEN)
CONFIGURE_FILE(simple.cxx.in ${DEEPSRC} COPYONLY)
+ # Watcom WMake seems to have problems with long command lines. Just
+ # disable this part of the test until it is resolved.
+ IF(${CMAKE_GENERATOR} MATCHES "Watcom WMake")
+ SET(DEEPSRC "")
+ ADD_DEFINITIONS(-DNO_DEEPSRC)
+ ENDIF(${CMAKE_GENERATOR} MATCHES "Watcom WMake")
+
ADD_LIBRARY(testlib testlib.cxx)
ADD_EXECUTABLE (simple simple.cxx ../simple.cxx ${DEEPSRC})
TARGET_LINK_LIBRARIES(simple testlib outlib)