summaryrefslogtreecommitdiffstats
path: root/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
index 9f7b868..c7cc090 100644
--- a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
+++ b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
@@ -20,9 +20,9 @@ IF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
# path of the source file for no good reason. Reduce the length
# limit by 46 characters to account for it. It should still be long
# enough to require special object file name conversion.
- IF(${CMAKE_GENERATOR} MATCHES "Visual Studio 8")
+ IF(${CMAKE_GENERATOR} MATCHES "Visual Studio (8|10)")
MATH(EXPR MAXPATH "${MAXPATH} - 46")
- ENDIF(${CMAKE_GENERATOR} MATCHES "Visual Studio 8")
+ ENDIF()
# MAXPATH less 25 for last /and/deeper/simple.cxx part and small safety
MATH(EXPR MAXPATH "${MAXPATH} - 25")