summaryrefslogtreecommitdiffstats
path: root/Tests/Plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Plugin/CMakeLists.txt')
-rw-r--r--Tests/Plugin/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/Plugin/CMakeLists.txt b/Tests/Plugin/CMakeLists.txt
index 41fd05f..a0d1add 100644
--- a/Tests/Plugin/CMakeLists.txt
+++ b/Tests/Plugin/CMakeLists.txt
@@ -11,6 +11,13 @@ SET(KWSYS_NAMESPACE kwsys)
SET(KWSYS_HEADER_ROOT ${Plugin_BINARY_DIR}/include)
SET(KWSYS_USE_DynamicLoader 1)
ADD_SUBDIRECTORY(${Plugin_SOURCE_DIR}/../../Source/kwsys src/kwsys)
+
+# Configure the location of plugins.
+CONFIGURE_FILE(${Plugin_SOURCE_DIR}/src/example_exe.h.in
+ ${Plugin_BINARY_DIR}/include/example_exe.h @ONLY)
+
+# We need to include headers from the source tree and configured
+# headers in the build tree.
INCLUDE_DIRECTORIES(
${Plugin_BINARY_DIR}/include
${Plugin_SOURCE_DIR}/include