summaryrefslogtreecommitdiffstats
path: root/Tests/Properties/SubDir2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Properties/SubDir2/CMakeLists.txt')
-rw-r--r--Tests/Properties/SubDir2/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/Properties/SubDir2/CMakeLists.txt b/Tests/Properties/SubDir2/CMakeLists.txt
index 9b2c79e..88e5531 100644
--- a/Tests/Properties/SubDir2/CMakeLists.txt
+++ b/Tests/Properties/SubDir2/CMakeLists.txt
@@ -28,3 +28,7 @@ generate_file_for_set_property_test(23 set_prop_lib_3)
# For set_source_files_properties + multiple files in multiple directories
generate_file_for_set_property_test(31 set_prop_lib_3)
+
+# For specifying both DIRECTORY and TARGET_DIRECTORY
+target_sources(set_prop_lib_3 PRIVATE "${CMAKE_CURRENT_BINARY_DIR}/../src32.cpp")
+target_sources(set_prop_lib_3 PRIVATE "${CMAKE_CURRENT_BINARY_DIR}/../src33.cpp")